Breezy e Creative WebCam Live!

Ho comprato dopo qualche ricerca la Creative Live! Webcam conscio che è una delle poche compatibili con linux, ed il mio disappunto, quando ho inserito la presa usb nel pc, nel vedere che il sistema si bloccava è stato abbastanza elevato.

Per fortuna ho trovato subito sul forum di ubuntu la soluzione al problema, che è essenzialmente una cattiva compilazione del modulo con i drivers usb del CMOS della webcam.

Facendo un riassunto del post sul forum per far andare la webcam basta scaricare i nuovi drivers e ricompilarli.

Aprite quindi una shell e fate partire il download dei drivers

$#wget http://mxhaard.free.fr/spca50x/Download/spca5xx-20051101.tar.gz
$#tar -xzvf spca5xx-20051101.tar.gz
$#cd spca5xx-20051101.tar.gz

prima di proseguire controllate di avere i seguenti pacchetti installati sul vostro sistema:

  • linux-headers-`uname -r`
  • linux-restricted-modules-`uname -r`
  • build-essential
  • gcc-3.4

sostituendo ad `uname -r` il risultato del comando (ie. 2.6.12-9-686) in modo da essere sicuri che gli header del kernel e dei moduli che avete già sul sistema siano presenti. Se non lo sono installate tutto tramite apt-get o synaptic.

A questo punto riprendete in mano la shell e digitate:

$#sudo -s
$#CC=gcc-3.4
$#export CC
$#make
$#modprobe -r spca5xx
$#rm -rf /lib/modules/`uname -r`/kernel/drivers/usb/media/spca5xx*
$#make install
$#modprobe spca5xx

io ho dovuto riavviare il sistema perchè il modulo non era stato caricato bene, ma se avete fortuna non dovrebbe succedervi.

Adesso potete riaprire gnomemeeting o camtasia senza incorrere nel maledetto freeze di sistema!

ciuaz

  • Io con ubuntu ho usato una “vecchia” Logitech QuickCam, marchiata Dexxa. Ci sono i drivers come sorgente in apt e van compilati preassapoco seguendo la stessa procedura.

  • Mario

    Ciao!
    ho provato a seguire le tue istruzioni sul mio Ubunti.. tutto bene sino all’ultima riga di comando: quando digito da shell $#modprobe spca5xx mi dice :
    >

    mi sapresti dare una mano??
    ti ringrazio,
    Mario

  • ivo

    anche a me da problemi l’ultimo comando

    FATAL: Error inserting spca5xx (/lib/modules/2.6.17-10-386/kernel/drivers/usb/media/spca5xx.ko): Invalid module format

  • moamahi

    Mario
    Devi togliere i : “due punti”
    IVO
    Probabilmente hai gcc o i sorgenti del kernel errati

    moamahii

  • idnob

    ivo,usa i gcc 4.0,vedrai che va tutto…

  • Mario

    ciao
    vorrei scusarmi per il mio post precedente lacunoso.. ad ogni modo l’errore era lo stesso di ivo.
    ho provato a utilizzare i gcc-4.0 ed effettivamente il messaggio di errore non me lo da.. ma la webcam non va comunque..

  • ivo

    io avevi quasi rinunciato a installare la webcam su Linux.
    Adesso ho fatto l’aggiornamento di linux dalle Ubuntu 6.06 alla kubuntu 6.10
    vediamo se mi funziona ! poi vi faccio sapere in maniera molto dettagliata come fare

  • Razor

    ho fatto tutto, ma quando lancio camorama mi da il solito errore, mi dice che non trova dev/video0, che posso fare?

  • andrea

    E’ meglio e più semplice seguire la guida presente all’interno dei driver (almeno per quanto riguarda i driver gspcav).
    Ottima guida comunque.

  • ivo

    Ragazzi adesso ho la Unbuntu 8.04 non ho ancora provato la webcam, ci avevo rinunciato, qualcuno sa dirmi se con questa versione di Ubuntu funziona?

%d bloggers like this: