PHP 6 e MySQL 3.x

Pare che con PHP 6 si eliminerà il supporto all’estensione mysql per dare più ampio spazio a mysqli. Questo perchè la vecchia estensione, scritta per MySQL 3.x non supporta e non potrà mai supportare Unicode.

Anche se la notizia sembra da poco il problema è che moltissimi hosting offrono ancora come unico database MySQL 3.x e quelli che hanno MySQL 5.x e l’estensione mysqli si contano sulla punta delle dita. Speriamo solo di non rivedere quello che è successo con php5, dove una lenta diffusione del nuovo engine ha impedito alla comunità di crescere ed evolversi seriamente.

ciuaz

%d bloggers like this: